RSS

Category Archives: Bug

Windows Server App Fabric is not correctly configured – SharePoint 2013 Setup Errors


When installing SharePoint 2013 SP1 prerequisites on Windows Server 2008 R2, the prerequisite installer fails with the following error

Error

image_thumb

“Windows Server App Fabric is not correctly configured. You should uninstall Windows Server Appfabric and reinstall it using the Sharepoint Products Preparation Tool.”

Cause
This occurs when u try to run “PREREQUISITEINSTALLER.exe” as standalone installation.

Resolution
The resolution is to run “prerequisiteinstaller.exe” with command line parameters to directly specify the file name for each prerequisite.

  1. Uninstall exisiting installation of AppFabric
  2. Delete “PSModulePath” from system environment variables entry.
  3. Restart server
  4. Open command prompt
  5. Navigate to SharePoint 2013 setup files folder (eg: D:\)
  6. Type following line
    prerequisiteInstaller.exe /appfabric:Z:\Softwares\Sharepoint 2013PreRequisite\WindowsServerAppFabricSetup_x64.exe
    (NOTE:  Z: is my Prerequisite files folder location. replace with you path)
    MAKE SURE THERE IS NO SPACE FOR FOLDER NAME
    sp2013-prereq
  7. image_thumb_6
  8. Done! Continue installation…
Advertisements
 
3 Comments

Posted by on September 20, 2014 in Bug, SharePoint 2013, Tips & Tricks

 

Tags: ,

Resolved: Could not load file or assembly ‘Microsoft.SharePoint.Sandbox, Version=12.0.0.0, Culture=neutral, PublicKeyToken=XXXXXXXXX’ or one of its dependencies…


I have a remote sharepoint solution that contains SharePoint dll’s reference. Whenever I run the solution, start page get crash and show me this error.

“Could not load file or assembly ‘Microsoft.SharePoint.Sandbox, Version=12.0.0.0, Culture=neutral, PublicKeyToken=XXXXXXXX’ or one of its dependencies. An attempt was made to load a program with an incorrect format.”

Well every time I run the project it creates Microsoft.SharePoint.Sandbox.dll and Microsoft.SharePoint.Sandbox.xml inside the bin folder and it creates the problem. Well there are lots many things have written on web regarding this problem. I follow all these things but could not get rid of this error. Finally I decided to fix this problem according to my way. So below are the steps to fix this problem permanently.

1. Inside solution explorer (Visual Studio), select the project and right click on that.

2. From context menu, click on properties.

3. When properties page opens, Click on Build Events.

4. Under Post – build event command line, copy and paste below lines

cd $(TargetDir)

del Microsoft.SharePoint.Sandbox.dll

del Microsoft.SharePoint.Sandbox.xml

Done!

NOTE: please replace with your dll name.

 
 

Error occurred in deployment step ‘Recycle IIS Application Pool’: Provider load failure


The Bug

When you try to deploy or retract a SharePoint 2010 solution from visual studio 10 you get below error message:
Error occurred in deployment step ‘Recycle IIS Application Pool’: Provider load failure

Solution

Restart the SharePoint 2010 User Code Host service resolved the issue. Try below powershell command.

restart-service SPUserCodeV4

 
Leave a comment

Posted by on August 14, 2012 in Bug, Error, Sharepoint Server 2010, Webpart

 

Tags: ,

Attention: Important Information on Service Pack 2


During the installation of SP2, a product expiration date is improperly activated. This means SharePoint will expire as though it was a trial installation 180 days after SP2 is deployed. The activation of the expiration date will not affect the normal function of SharePoint up until the expiration date passes. Read Full Article

 
Leave a comment

Posted by on May 23, 2009 in Bug, New Releases, Service Packs

 

Tags: ,